Setup LVM based Intrepid Server PV DomU for PV-Grub load at Xen 3.3.1-RC4 CentOS 5.2 Dom0

Been creating Intrepid (lbex) HVM image,supposed to be loaded as PV DomU, i’ve got an issue with default LVM partitioning been done by Ubuntu Intrepid Server. Image been created may be easily loaded at Xen 3.3.X Dom0 via traditional xm-profile by not via “pygrub” or “pv-grub”, expecting /boot partition not of LVM’s type. Up on creating Intrepid HVM image, boot partition and LVM’s Group , containing “/” filesystem and swap as logical volumes have been setup.Notice,that Disk Druid RH’s partitioner always does so by default.
Intrepid KVM with image device (/dev/sdb8) has been created via virt-manager on Ubuntu Intrepid Server dual booting with
Xen 3.3.1 CentOS 5.2 Dom0. Actually, it’s not important where to create this image. It could be also done via standard hvm profile at Xen 3.3.1 CentOS 5.2 Dom0. I have to notice, that “qcow2″ format for image files supported by the most recent python-vm-builder for intrepid’s KVMs is not acceptable for convertion into PV DomU’s images.



Setting up Intrepid HVM at Xen 3.3.1-RC4 CentOS 5.2 Dom0 :-















Once HVM got loaded /etc/event.d/tty1 has been copied to /etc/event.d/hvc0

# tty1 - getty
#
# This service maintains a getty on tty1 from the point the system is
# started until it is shut down again.
start on stopped rc2
start on stopped rc3
start on stopped rc4
start on stopped rc5
stop on runlevel 0
stop on runlevel 1
stop on runlevel 6
respawn
exec /sbin/getty 38400 hvc0

The first time Intrepid PV DomU has been loaded via profile :

[root@dhcppc0 vm]# cat xen.conf
name = 'UbuntuPVS810'
memory = 4096
kernel = '/etc/xen/vm/vmlinuz-2.6.27-7-server'
ramdisk = '/etc/xen/vm/initrd.img-2.6.27-7-server'
disk = [ 'phy:/dev/sdb8,xvda,w']
vif = [ 'bridge = eth0']
on_poweroff = 'destroy'
on_reboot = 'restart'
on_crash = 'restart'
root = '/dev/mapper/vg01-vol01 ro'
extra = '2 console=hvc0'

At DomU side :-

# apt-get vim
# apt-get upgrade
# apt-get linux-server-image

have been run.
File /boot/grub/menu.lst modified as follows :-

title Ubuntu 8.10, kernel 2.6.27-9-server (PV DomU)
root (hd0,0)
kernel /vmlinuz-2.6.27-9-server root=/dev/mapper/vg01-vol01 ro 2 console=hvc0
initrd /initrd.img-2.6.27-9-server
quiet

Then Intrepid PV DomU may be loaded via profile :-

[root@dhcppc0 vm]# cat IntrepidPVG.pv-grub
name = "InterpidPV-Grub"
memory = 4096
vcpus = 1
disk = [ 'phy:/dev/sdb8,xvda,w' ]
vif = [ "bridge=eth0" ]
kernel = "/usr/lib/xen/boot/pv-grub-x86_64.gz"
extra = "(hd0,0)/grub/menu.lst"

Startup log

[root@ServerXen331 vm]# xm create -c IntrepidPVG.pv-grub
Using config file "./IntrepidPVG.pv-grub".
Started domain InterpidPV-Grub
Xen Minimal OS!
start_info: 0x118d000
nr_pages: 1048576 shared_inf: ceff0000
Booting 'Ubuntu 8.10, kernel 2.6.27-9-server (PV DomU)'
root (hd0,0)
Filesystem type is ext2fs, partition type 0x83
kernel /vmlinuz-2.6.27-9-server root=/dev/mapper/vg01-vol01 ro 2 console=hvc0
initrd /initrd.img-2.6.27-9-server
close blk: backend at /local/domain/0/backend/vbd/1/51712
[ 0.000000] Initializing cgroup subsys cpuset
[ 0.000000] Initializing cgroup subsys cpu
[ 0.000000] Linux version 2.6.27-9-server (buildd@yellow) (gcc version 4.3.2 (Ubuntu 4.3.2-1ubuntu11) ) #1 SMP Thu Nov 20 22:56:07 UTC 2008 (Ubuntu 2.6.27-9.19-server)
[ 0.000000] Command line: root=/dev/mapper/vg01-vol01 ro 2 console=hvc0
[ 0.000000] KERNEL supported cpus:
[ 0.000000] Intel GenuineIntel
[ 0.000000] AMD AuthenticAMD
[ 0.000000] Centaur CentaurHauls
[ 0.000000] ACPI in unprivileged domain disabled
[ 0.000000] BIOS-provided physical RAM map:
[ 0.000000] Xen: 0000000000000000 - 00000000000a0000 (usable)
[ 0.000000] Xen: 00000000000a0000 - 0000000000100000 (reserved)
[ 0.000000] Xen: 0000000000100000 - 0000000002251000 (usable)
[ 0.000000] Xen: 0000000002251000 - 0000000002a54000 (reserved)
[ 0.000000] Xen: 0000000002a54000 - 0000000100000000 (usable)
[ 0.000000] last_pfn = 0x100000 max_arch_pfn = 0x3ffffffff
[ 0.000000] init_memory_mapping
[ 0.000000] last_map_addr: 100000000 end: 100000000
[ 0.000000] RAMDISK: 008b9000 - 02251000
[ 0.000000] DMI not present or invalid.
[ 0.000000] No NUMA configuration found
[ 0.000000] Faking a node at 0000000000000000-0000000100000000
[ 0.000000] Bootmem setup node 0 0000000000000000-0000000100000000
[ 0.000000] NODE_DATA [0000000000001000 - 0000000000005fff]
[ 0.000000] bootmap [0000000000008000 - 0000000000027fff] pages 20
[ 0.000000] (6 early reservations) ==> bootmem [0000000000 - 0100000000]
[ 0.000000] #0 [0000000000 - 0000001000] BIOS data page ==> [0000000000 - 0000001000]
[ 0.000000] #1 [0000006000 - 0000008000] TRAMPOLINE ==> [0000006000 - 0000008000]
[ 0.000000] #2 [0002a54000 - 0002a6d000] XEN PAGETABLES ==> [0002a54000 - 0002a6d000]
[ 0.000000] #3 [0000200000 - 00008b8f9c] TEXT DATA BSS ==> [0000200000 - 00008b8f9c]
[ 0.000000] #4 [00008b9000 - 0002251000] RAMDISK ==> [00008b9000 - 0002251000]
[ 0.000000] #5 [0002a6d000 - 0003256000] PGTABLE ==> [0002a6d000 - 0003256000]
[ 0.000000] Zone PFN ranges:
[ 0.000000] DMA 0x00000000 -> 0x00001000
[ 0.000000] DMA32 0x00001000 -> 0x00100000
[ 0.000000] Normal 0x00100000 -> 0x00100000
[ 0.000000] Movable zone start PFN for each node
[ 0.000000] early_node_map[3] active PFN ranges
[ 0.000000] 0: 0x00000000 -> 0x000000a0
[ 0.000000] 0: 0x00000100 -> 0x00002251
[ 0.000000] 0: 0x00002a54 -> 0x00100000
[ 0.000000] SMP: Allowing 1 CPUs, 0 hotplug CPUs
[ 0.000000] No local APIC present
[ 0.000000] PM: Registered nosave memory: 00000000000a0000 - 0000000000100000
[ 0.000000] PM: Registered nosave memory: 0000000002251000 - 0000000002a54000
[ 0.000000] PCI: Warning: Cannot find a gap in the 32bit address range
[ 0.000000] PCI: Unassigned devices with 32bit resource registers may break!
[ 0.000000] Allocating PCI resources starting at 100200000 (gap: 100100000:400000)
[ 0.000000] PERCPU: Allocating 64928 bytes of per cpu data
[ 0.000000] Built 1 zonelists in Node order, mobility grouping on. Total pages: 1028322
[ 0.000000] Policy zone: DMA32
[ 0.000000] Kernel command line: root=/dev/mapper/vg01-vol01 ro 2 console=hvc0
[ 0.000000] Initializing CPU#0
[ 0.000000] PID hash table entries: 4096 (order: 12, 32768 bytes)
[ 0.000000] Detected 3005.554 MHz processor.
[ 0.010000] Console: colour dummy device 80x25
[ 0.010000] console [tty0] enabled
[ 0.010000] console [hvc0] enabled
[ 0.010000] Checking aperture...
[ 0.010000] No AGP bridge found
[ 0.010000] Memory: 4078468k/4194304k available (3111k kernel code, 107248k reserved, 1577k data, 536k init)
[ 0.010000] SLUB: Genslabs=13, HWalign=64, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[ 0.010000] installing Xen timer for CPU 0
[ 0.010000] Calibrating delay loop (skipped), value calculated using timer frequency.. 6011.10 BogoMIPS (lpj=30055540)
[ 0.010000] Security Framework initialized
[ 0.010000] SELinux: Disabled at boot.
[ 0.010000] AppArmor: AppArmor initialized
[ 0.010000] Dentry cache hash table entries: 524288 (order: 10, 4194304 bytes)
[ 0.010000] Inode-cache hash table entries: 262144 (order: 9, 2097152 bytes)
[ 0.010000] Mount-cache hash table entries: 256
[ 0.010000] Initializing cgroup subsys ns
[ 0.010000] Initializing cgroup subsys cpuacct
[ 0.010000] Initializing cgroup subsys memory
[ 0.010000] CPU: L1 I cache: 32K, L1 D cache: 32K
[ 0.010000] CPU: L2 cache: 6144K
[ 0.010000] CPU 0/0 -> Node 0
[ 0.010000] CPU: Physical Processor ID: 0
[ 0.010000] CPU: Processor Core ID: 0
[ 0.010000] SMP alternatives: switching to UP code
[ 0.016842] Freeing SMP alternatives: 24k freed
[ 0.016895] cpu 0 spinlock event irq 1
[ 0.016954] Brought up 1 CPUs
[ 0.017209] net_namespace: 1552 bytes
[ 0.017216] Booting paravirtualized kernel on Xen
[ 0.017219] Xen version: 3.3.1-rc4 (preserve-AD)
[ 0.017317] Grant table initialized
[ 0.037343] Time: 165:165:165 Date: 165/165/65
[ 0.037366] NET: Registered protocol family 16
[ 0.040123] PCI: Fatal: No config space access function found
[ 0.040780] ACPI: Interpreter disabled.
[ 0.040785] Linux Plug and Play Support v0.97 (c) Adam Belay
[ 0.040814] pnp: PnP ACPI: disabled
[ 0.040824] xen_balloon: Initialising balloon driver.
[ 0.040824] PCI: System does not support PCI
[ 0.040824] PCI: System does not support PCI
[ 0.070048] NET: Registered protocol family 8
[ 0.070054] NET: Registered protocol family 20
[ 0.070086] NetLabel: Initializing
[ 0.070090] NetLabel: domain hash size = 128
[ 0.070093] NetLabel: protocols = UNLABELED CIPSOv4
[ 0.070105] NetLabel: unlabeled traffic allowed by default
[ 0.070111] PCI-GART: No AMD northbridge found.
[ 0.070438] tracer: 1286 pages allocated for 65536 entries of 80 bytes
[ 0.070443] actual entries 65586
[ 0.070511] AppArmor: AppArmor Filesystem Enabled
[ 0.070902] NET: Registered protocol family 2
[ 0.160144] IP route cache hash table entries: 131072 (order: 8, 1048576 bytes)
[ 0.161337] TCP established hash table entries: 524288 (order: 11, 8388608 bytes)
[ 0.164068] TCP bind hash table entries: 65536 (order: 8, 1048576 bytes)
[ 0.164490] TCP: Hash tables configured (established 524288 bind 65536)
[ 0.164495] TCP reno registered
[ 0.190086] NET: Registered protocol family 1
[ 0.190168] checking if image is initramfs... it is
[ 0.207743] Freeing initrd memory: 26208k freed
[ 0.215888] platform rtc_cmos: registered platform RTC device (no PNP device found)
[ 0.216287] audit: initializing netlink socket (disabled)
[ 0.216302] type=2000 audit(1230734886.996:1): initialized
[ 0.220775] HugeTLB registered 2 MB page size, pre-allocated 0 pages
[ 0.223202] VFS: Disk quotas dquot_6.5.1
[ 0.223281] Dquot-cache hash table entries: 512 (order 0, 4096 bytes)
[ 0.223371] msgmni has been set to 8243
[ 0.223472] io scheduler noop registered
[ 0.223476] io scheduler anticipatory registered
[ 0.223480] io scheduler deadline registered (default)
[ 0.223596] io scheduler cfq registered
[ 0.251350] Linux agpgart interface v0.103
[ 0.251361] Serial: 8250/16550 driver4 ports, IRQ sharing enabled
[ 0.253154] brd: module loaded
[ 0.253215] input: Macintosh mouse button emulation as /devices/virtual/input/input0
[ 0.253369] PNP: No PS/2 controller found. Probing ports directly.
[ 0.254190] i8042.c: No controller found.
[ 0.270584] mice: PS/2 mouse device common for all mice
[ 0.270631] rtc_cmos: probe of rtc_cmos failed with error -16
[ 0.270708] cpuidle: using governor ladder
[ 0.270711] cpuidle: using governor menu
[ 0.270954] TCP cubic registered
[ 0.270969] IO APIC resources could be not be allocated.
[ 0.271132] registered taskstats version 1
[ 0.271143] XENBUS: Device with no driver: device/vbd/51712
[ 0.271147] XENBUS: Device with no driver: device/vif/0
[ 0.271150] XENBUS: Device with no driver: device/console/0
[ 0.271161] Magic number: 1:252:3141
[ 0.271232] /build/buildd/linux-2.6.27/drivers/rtc/hctosys.c: unable to open rtc device (rtc0)
[ 0.271239] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 0.271242] EDD information not available.
[ 0.271260] Freeing unused kernel memory: 536k freed
[ 0.271402] Write protecting the kernel read-only data: 4348k
Loading, please wait...
Couldnt get a file descriptor referring to the console
Begin: Loading essential drivers... ...
[ 0.353491] fuse init (API version 7.9)
[ 0.400923] thermal: Unknown symbol acpi_processor_set_thermal_limit
[ 0.411210] device-mapper: uevent: version 1.0.3
[ 0.411363] device-mapper: ioctl: 4.14.0-ioctl (2008-04-23) initialised: dm-devel@redhat.com
Done.
Begin: Running /scripts/init-premount ...
Done.
Begin: Mounting root file system... ...
Begin: Running /scripts/local-top ...
Done.
Begin: Waiting for root file system... ...
[ 1.138334] blkfront: xvda: barriers enabled
[ 1.138636] xvda: xvda1 xvda2
Done.
Begin: Running /scripts/local-premount ...
19+0 records in
19+0 records out
kinit: name_to_dev_t(/dev/mapper/vg01-vol02) = dev(254,1)
kinit: trying to resume from /dev/mapper/vg01-vol02
[ 1.508634] PM: Starting manual resume from disk
kinit: No resume image, doing normal boot...
Done.
[ 1.553487] kjournald starting. Commit interval 5 seconds
[ 1.553499] EXT3-fs: mounted filesystem with ordered data mode.
Begin: Running /scripts/local-bottom ...
Done.
Done.
Begin: Running /scripts/init-bottom ...
Done.
* Setting preliminary keymap... [ OK ]
* Setting the system clock
Cannot access the Hardware Clock via any known method.
Use the --debug option to see the details of our search for an access method.
* Unable to set System Clock to: Wed Dec 31 14:48:09 UTC 2008
* Starting basic networking... [ OK ]
* Starting kernel event manager... [ 2.754835] udevd version 124 started
[ OK ]
* Loading hardware drivers... [ 3.064621] Initialising Xen virtual ethernet driver.
[ 3.076929] input: PC Speaker as /devices/platform/pcspkr/input/input1
[ OK ]
* Setting the system clock
Cannot access the Hardware Clock via any known method.
Use the --debug option to see the details of our search for an access method.
* Unable to set System Clock to: Wed Dec 31 14:48:10 UTC 2008
* Loading kernel modules... * Loading manual drivers... [ 4.045033] loop: module loaded
[ 4.100426] lp: driver loaded but no devices found
[ OK ]
* Setting kernel variables (/etc/sysctl.conf)... [ OK ]
* Setting kernel variables (/etc/sysctl.d/10-console-messages.conf)... [ OK ]
* Setting kernel variables (/etc/sysctl.d/10-network-security.conf)... [ OK ]
* Setting kernel variables (/etc/sysctl.d/10-process-security.conf)... [ OK ]
* Activating swap... [ OK ]
* Checking root file system... fsck 1.41.3 (12-Oct-2008)
/dev/mapper/vg01-vol01: clean, 26035/765536 files, 263631/3058688 blocks
[ OK ]
* Checking file systems... fsck 1.41.3 (12-Oct-2008)
/dev/xvda1: clean, 38/122880 files, 52386/489948 blocks
[ OK ]
* Mounting local filesystems... [ OK ]
* Activating swapfile swap... [ OK ]
$Mounting securityfs on /sys/kernel/security: done.
Loading AppArmor profiles : done.
* Skipping firewall: ufw (not enabled)... [ OK ]
* Configuring network interfaces... [ OK ]
* Setting up console font and keymap... [ OK ]
* Starting system log daemon... [ OK ]
* Starting kernel log daemon... [ OK ]
* Starting system message bus dbus [ OK ]
* Starting OpenBSD Secure Shell server sshd [ OK ]
* Starting deferred execution scheduler atd [ OK ]
* Starting periodic command scheduler crond [ OK ]

Ubuntu 8.10 UbuntuSRV hvc0

UbuntuSRV login: root
Password:
Last login: Wed Dec 31 07:06:32 EST 2008 on hvc0
Linux UbuntuSRV 2.6.27-9-server #1 SMP Thu Nov 20 22:56:07 UTC 2008 x86_64

The programs included with the Ubuntu system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Ubuntu comes with ABSOLUTELY NO WARRANTY, to the extent permitted by
applicable law.

To access official Ubuntu documentation, please visit:

http://help.ubuntu.com/

root@UbuntuSRV:~#


At Dom0 side Intrepid Server PV DomU’s configuration looks like :-

[root@ServerXen331 ~]# xm list -l InterpidPV-Grub
(domain
(domid 1)
(on_crash restart)
(uuid e622894a-7c14-b6b2-fc3d-58f5628002d0)
(bootloader_args )
(vcpus 1)
(name InterpidPV-Grub)
(on_poweroff destroy)
(on_reboot restart)
(bootloader )
(maxmem 4096)
(memory 4096)
(shadow_memory 0)
(features )
(on_xend_start ignore)
(on_xend_stop ignore)
(start_time 1230734876.15)
(cpu_time 13.595148826)
(online_vcpus 1)
(image
(linux
(kernel /usr/lib/xen/boot/pv-grub-x86_64.gz)
(args '(hd0,0)/grub/menu.lst')
(notes)
)
)
(status 2)
(state -b----)
(store_mfn 2211302)
(console_mfn 2211301)
(device
(vif
(bridge eth0)
(mac 00:16:3e:31:42:b7)
(script /etc/xen/scripts/vif-bridge)
(uuid 55c1e4ae-34b6-2f4a-7ed1-43a5fdfc13d9)
(backend 0)
)
)
(device
(vbd
(protocol x86_64-abi)
(uuid a8da65b0-382a-d8ed-d54d-8b9670b2e0d9)
(dev xvda:disk)
(uname phy:/dev/sdb8)
(mode w)
(backend 0)
(bootable 1)
(VDI )
)
)
(device
(console
(protocol vt100)
(location 2)
(uuid 9c764e32-0f57-78b9-f228-2504c16be5f2)
)
)
)

Ubuntu Desktop has been installed via tasksel
and vnc has been set up at PV DomU :-



About these ads

2 Responses to Setup LVM based Intrepid Server PV DomU for PV-Grub load at Xen 3.3.1-RC4 CentOS 5.2 Dom0

  1. [...] Setup LVM based Intrepid Server PV DomU for PV-Grub load at Xen 3.3.1-RC4 CentOS 5.2 Dom0 Posted by suvi under Virtualization Been creating Intrepid (lbex) HVM image,supposed to be loaded as PV DomU, i’ve got an issue with default LVM partitioning been done by Ubuntu Intrepid Server. Image been created may be easily loaded at Xen 3.3.X Dom0 via traditional xm-profile by not via “pygrub” or “pv-grub”, expecting /boot partition not of LVM’s type. Up on creating Intrepid HVM image, boot partition and LVM’s Group , containing “/” filesystem and swap as logical volumes have been setup.Notice,that Disk Druid RH’s partitioner always does so by default. Intrepid KVM with image device (/dev/sdb8) has been created via virt-manager on Ubuntu Intrepid Server dual booting with Xen 3.3.1 CentOS 5.2 Dom0. Read more …. [...]

  2. Alexwebmaster says:

    Hello webmaster
    I would like to share with you a link to your site
    write me here preonrelt@mail.ru

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Follow

Get every new post delivered to your Inbox.

%d bloggers like this: